Armeniam language locale for Armenia.
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # This file can use cpp-style conditionals starting with % instead of #
9 # to test the symbols defined in config.h by configure.
10
11 # In the optional third column, there can one or more symbol set names
12 # listed, which must be in ascending version order reading left to right
13 # and must appear in this same order in the Versions.def file.  Each listed
14 # version subsumes all prior versions back to the previous listed version.
15 #
16 # An entry with DEFAULT in the second column gives a default third column
17 # to apply on matching configurations when the matching entry for a particular
18 # library has no third column.  The defaults must precede the entries they
19 # apply to.
20
21 # Configuration         DEFAULT                 Earliest symbol set
22 # -------------         ---------------         ------------------------------
23
24 s390x-.*-linux.*        DEFAULT                 GLIBC_2.2
25 cris-.*-linux.*         DEFAULT                 GLIBC_2.2
26 %if defined(USE_IN_LIBIO) && !defined(GLIBC_OLDEST_ABI)
27 // If you use configure --enable-libio --enable-oldest-abi=2.0 then we
28 // won't rename the old version sets and all the libraries except libc
29 // itself ought to be binary compatible with the libc.so.0.2 ABI.
30 .*-.*-gnu-gnu.*         DEFAULT                 GLIBC_2.2.4
31 %endif
32
33 # Configuration         Library=version         Earliest symbol set (optional)
34 # -------------         ---------------         ------------------------------
35
36 # The interface to -lm depends mostly only on cpu, not on operating system.
37 sparc64-.*-linux.*      libm=6                  GLIBC_2.2
38 alpha.*-.*-linux.*      libm=6.1
39 mips.*-.*-linux.*       libm=6                  GLIBC_2.0 GLIBC_2.2
40 ia64-.*-linux.*         libm=6.1                GLIBC_2.2
41 sh.*-.*-linux.*         libm=6                  GLIBC_2.2
42 hppa.*-.*-.*            libm=6                  GLIBC_2.2
43 .*-.*-linux.*           libm=6
44 .*-.*-gnu-gnu.*         libm=6
45
46 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
47 alpha.*-.*-linux.*      libc=6.1
48 # Working mips versions were never released between 2.0 and 2.2.
49 mips.*-.*-linux.*       libc=6                  GLIBC_2.0 GLIBC_2.2
50 ia64-.*-linux.*         libc=6.1                GLIBC_2.2
51 sh.*-.*-linux.*         libc=6                  GLIBC_2.2
52 sparc64-.*-linux.*      libc=6                  GLIBC_2.2
53 hppa.*-.*-.*            libc=6                  GLIBC_2.2
54 .*-.*-linux.*           libc=6
55
56 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
57 .*-.*-gnu-gnu.*         libmachuser=1
58
59 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
60 .*-.*-gnu-gnu.*         libhurduser=0.0
61
62 %ifndef USE_IN_LIBIO
63 # libc.so.0.2 is for the Hurd alpha release 0.2.
64 .*-.*-gnu-gnu.*         libc=0.2
65 %else
66 # libc.so.0.3 is the first Hurd libc using libio.
67 .*-.*-gnu-gnu.*         libc=0.3
68 %endif
69
70 # The dynamic loader also requires different names.
71 i.86-.*-linux.*         ld=ld-linux.so.2
72 sparc64-.*-linux.*      ld=ld-linux.so.2        GLIBC_2.2
73 sparc.*-.*-linux.*      ld=ld-linux.so.2
74 alpha.*-.*-linux.*      ld=ld-linux.so.2
75 arm.*-.*-linux.*        ld=ld-linux.so.2
76 sh.*-.*-linux.*         ld=ld-linux.so.2        GLIBC_2.2
77 ia64-.*-linux.*         ld=ld-linux-ia64.so.2   GLIBC_2.2
78 mips.*-.*-linux.*       ld=ld.so.1              GLIBC_2.0 GLIBC_2.2
79 hppa.*-.*-.*            ld=ld.so.1              GLIBC_2.2
80 s390x-.*-linux.*        ld=ld64.so.1            GLIBC_2.2
81 cris-.*-linux.*         ld=ld.so.1              GLIBC_2.2
82 # We use the ELF ABI standard name for the default.
83 .*-.*-.*                ld=ld.so.1
84
85 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
86 alpha.*-.*-linux.*      libdl=2.1
87 mips.*-.*-linux.*       libdl=2                 GLIBC_2.0 GLIBC_2.2
88 .*-.*-.*                libdl=2
89
90 # So far the -lutil interface is the same on all platforms, except for the
91 # `struct utmp' format, which depends on libc.
92 alpha.*-.*-linux.*      libutil=1.1
93 .*-.*-.*                libutil=1
94
95 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
96 # interface.
97 alpha.*-.*-linux.*      libresolv=2.1
98 mips.*-.*-linux.*       libresolv=2             GLIBC_2.0 GLIBC_2.2
99 .*-.*-.*                libresolv=2
100
101 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
102 # in nss/nsswitch.h, which determines the library names used for service
103 # names given in /etc/nsswitch.conf.
104 mips.*-.*-linux.*       libnss_files=2          GLIBC_2.0 GLIBC_2.2
105 mips.*-.*-linux.*       libnss_dns=2            GLIBC_2.0 GLIBC_2.2
106 mips.*-.*-linux.*       libnss_compat=2         GLIBC_2.0 GLIBC_2.2
107 mips.*-.*-linux.*       libnss_nis=2            GLIBC_2.0 GLIBC_2.2
108 mips.*-.*-linux.*       libnss_nisplus=2        GLIBC_2.0 GLIBC_2.2
109 mips.*-.*-linux.*       libnss_ldap=2           GLIBC_2.0 GLIBC_2.2
110 mips.*-.*-linux.*       libnss_hesiod=2         GLIBC_2.0 GLIBC_2.2
111 .*-.*-.*                libnss_files=2
112 .*-.*-.*                libnss_dns=2
113 .*-.*-.*                libnss_compat=2
114 .*-.*-.*                libnss_nis=2
115 .*-.*-.*                libnss_nisplus=2
116 .*-.*-.*                libnss_ldap=2
117 .*-.*-.*                libnss_hesiod=2
118
119 # Version for libnsl with YP and NIS+ functions.
120 alpha.*-.*-linux.*      libnsl=1.1
121 mips.*-.*-linux.*       libnsl=1                GLIBC_2.0 GLIBC_2.2
122 .*-.*-.*                libnsl=1
123
124 # This defines the shared library version numbers we will install.
125 alpha.*-.*-linux.*      libcrypt=1.1
126 .*-.*-.*                libcrypt=1
127
128 # The gross patch for programs assuming broken locale implementations.
129 alpha.*-.*-linux.*      libBrokenLocale=1.1
130 ia64-.*-.*              libBrokenLocale=1       GLIBC_2.2
131 sh.*-.*-.*              libBrokenLocale=1       GLIBC_2.2
132 sparc64-.*-.*           libBrokenLocale=1       GLIBC_2.2
133 hppa-.*-.*              libBrokenLocale=1       GLIBC_2.2
134 .*-.*-.*                libBrokenLocale=1
135
136 # The real-time library from POSIX.1b.
137 mips.*-.*-linux.*       librt=1                 GLIBC_2.0 GLIBC_2.2
138 .*-.*-.*                librt=1
139
140 # The asynchronous name lookup library.
141 .*-.*-.*                libanl=1