.
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # Configuration         Library versions
9 # -------------         ------- --------
10
11 # The interface to -lm depends mostly only on cpu, not on operating system.
12 i.86-.*-.*              libm=6
13 m68k-.*-.*              libm=6
14 sparc-.*-.*             libm=6
15 sparc64-.*-.*           libm=6
16 alpha.*-.*-linux.*      libm=6.1
17 alpha.*-.*-.*           libm=6
18 powerpc-.*-.*           libm=6
19 mips-.*-.*              libm=6
20 arm.*-.*-.*             libm=6
21
22 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
23 alpha.*-.*-linux.*      libc=6.1
24 .*-.*-linux.*           libc=6
25
26 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
27 .*-.*-gnu-gnu.*         libmachuser=1
28
29 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
30 .*-.*-gnu-gnu*          libhurduser=0.0
31
32 # libc.so.0.2 is for the Hurd alpha release 0.2.
33 .*-.*-gnu-gnu*          libc=0.2
34
35 # The dynamic loader also requires different names.
36 i.86-.*-linux.*         ld=ld-linux.so.2
37 sparc-.*-linux.*        ld=ld-linux.so.2
38 sparc64-.*-linux.*      ld=ld-linux64.so.2
39 alpha.*-.*-linux.*      ld=ld-linux.so.2
40 arm.*-.*-linux.*        ld=ld-linux.so.2
41 # We use the ELF ABI standard name for the default.
42 .*-.*-.*                ld=ld.so.1
43
44 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
45 alpha.*-.*-linux.*      libdl=2.1
46 .*-.*-.*                libdl=2
47
48 # So far the -lutil interface is the same on all platforms, except for the
49 # `struct utmp' format, which depends on libc.
50 alpha.*-.*-linux.*      libutil=1.1
51 .*-.*-.*                libutil=1
52
53 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
54 # interface.
55 alpha.*-.*-linux.*      libresolv=2.1
56 .*-.*-.*                libresolv=2
57
58 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
59 # in nss/nsswitch.h, which determines the library names used for service
60 # names given in /etc/nsswitch.conf.
61 .*-.*-.*                libnss_files=2
62 .*-.*-.*                libnss_dns=2
63 .*-.*-.*                libnss_db=2
64 .*-.*-.*                libnss_compat=2
65 .*-.*-.*                libnss_nis=2
66 .*-.*-.*                libnss_nisplus=2
67 .*-.*-.*                libnss_ldap=2
68 .*-.*-.*                libnss_hesiod=2
69
70 # Version for libnsl with YP and NIS+ functions.
71 alpha.*-.*-linux.*      libnsl=1.1
72 .*-.*-.*                libnsl=1
73
74 # We use libdb.so.3 for the interface in version 2.x of the Berkeley DB code.
75 .*-.*-.*                libdb=3
76 # This is the Berkeley DB 1.85.  We use the version numbers from glibc 2.0.*
77 # for all times.
78 alpha-.*-linux.*        libdb1=2.1
79 .*-.*-.*                libdb1=2
80
81 # This defines the shared library version numbers we will install.
82 alpha.*-.*-linux.*      libcrypt=1.1
83 .*-.*-.*                libcrypt=1
84
85 # The gross patch for programs assuming broken locale implementations.
86 alpha.*-.*-linux.*      libBrokenLocale=1.1
87 .*-.*-.*                libBrokenLocale=1
88
89 # The real-time library from POSIX.1b.
90 .*-.*-.*                librt=1