Don't use and define cistrcmp. We have strcasecmp.
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # Configuration         Library versions
9 # -------------         ------- --------
10
11 # The interface to -lm depends mostly only on cpu, not on operating system.
12 i.86-.*-.*              libm=6
13 m68k-.*-.*              libm=6
14 sparc-.*-.*             libm=6
15 sparc64-.*-.*           libm=6
16 alpha-.*-linux.*        libm=6.1
17 alpha-.*-.*             libm=6
18 powerpc-.*-.*           libm=6
19 mips-.*-.*              libm=6
20
21 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
22 alpha-.*-linux.*        libc=6.1
23 .*-.*-linux.*           libc=6
24
25 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
26 .*-.*-gnu-gnu.*         libmachuser=1
27
28 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
29 .*-.*-gnu-gnu*          libhurduser=0.0
30
31 # libc.so.0.2 is for the Hurd alpha release 0.2.
32 .*-.*-gnu-gnu*          libc=0.2
33
34 # The dynamic loader also requires different names.
35 i.86-.*-linux.*         ld=ld-linux.so.2
36 sparc-.*-linux.*        ld=ld-linux.so.2
37 sparc64-.*-linux.*      ld=ld-linux64.so.2
38 alpha-.*-linux.*        ld=ld-linux.so.2
39 # We use the ELF ABI standard name for the default.
40 .*-.*-.*                ld=ld.so.1
41
42 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
43 alpha-.*-linux.*        libdl=2.1
44 .*-.*-.*                libdl=2
45
46 # So far the -lutil interface is the same on all platforms, except for the
47 # `struct utmp' format, which depends on libc.
48 alpha-.*-linux.*        libutil=1.1
49 .*-.*-.*                libutil=1
50
51 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
52 # interface.
53 alpha-.*-linux.*        libresolv=2.1
54 .*-.*-.*                libresolv=2
55
56 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
57 # in nss/nsswitch.h, which determines the library names used for service
58 # names given in /etc/nsswitch.conf.
59 alpha-.*-linux.*        libnss_files=1.1
60 alpha-.*-linux.*        libnss_dns=1.1
61 alpha-.*-linux.*        libnss_db=1.1
62 alpha-.*-linux.*        libnss_compat=1.1
63 alpha-.*-linux.*        libnss_nis=1.1
64 alpha-.*-linux.*        libnss_nisplus=1.1
65 alpha-.*-linux.*        libnss_ldap=1.1
66 alpha-.*-linux.*        libnss_hesiod=1.1
67 .*-.*-.*                libnss_files=1
68 .*-.*-.*                libnss_dns=1
69 .*-.*-.*                libnss_db=1
70 .*-.*-.*                libnss_compat=1
71 .*-.*-.*                libnss_nis=1
72 .*-.*-.*                libnss_nisplus=1
73 .*-.*-.*                libnss_ldap=1
74 .*-.*-.*                libnss_hesiod=1
75
76 # Version for libnsl with YP and NIS+ functions.
77 alpha-.*-linux.*        libnsl=1.1
78 .*-.*-.*                libnsl=1
79
80 # We use libdb.so.3 for the interface in version 2.x of the Berkeley DB code.
81 .*-.*-.*                libdb=3
82
83 # This defines the shared library version numbers we will install.
84 alpha-.*-linux.*        libcrypt=1.1
85 .*-.*-.*                libcrypt=1
86
87 # The gross patch for programs assuming broken locale implementations.
88 alpha-.*-linux.*        libBrokenLocale=1.1
89 .*-.*-.*                libBrokenLocale=1