Bump ia64 soname to ld-linux-ia64.so.2 to mark change of objects to use 32 bit
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # This file can use cpp-style conditionals starting with % instead of #
9 # to test the symbols defined in config.h by configure.
10
11 # In the optional third column, there can one or more symbol set names
12 # listed, which must be in ascending version order reading left to right
13 # and must appear in this same order in the Versions.def file.  Each listed
14 # version subsumes all prior versions back to the previous listed version.
15
16 # Configuration         Library=version         Earliest symbol set (optional)
17 # -------------         ---------------         ------------------------------
18
19 # The interface to -lm depends mostly only on cpu, not on operating system.
20 i.86-.*-.*              libm=6
21 m68k-.*-.*              libm=6
22 sparc.*-.*-.*           libm=6
23 alpha.*-.*-linux.*      libm=6.1
24 alpha.*-.*-.*           libm=6
25 powerpc-.*-.*           libm=6
26 mips.*-.*-linux.*       libm=6                  GLIBC_2.0 GLIBC_2.2
27 mips.*-.*-.*            libm=6
28 arm.*-.*-.*             libm=6
29 ia64-.*-.*              libm=6.1                GLIBC_2.2
30 sh.*-.*-.*              libm=6                  GLIBC_2.2
31
32 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
33 alpha.*-.*-linux.*      libc=6.1
34 # Working mips versions were never released between 2.0 and 2.2.
35 mips.*-.*-linux.*       libc=6                  GLIBC_2.0 GLIBC_2.2
36 ia64-.*-.*              libc=6.1                GLIBC_2.2
37 sh.*-.*-.*              libc=6                  GLIBC_2.2
38 .*-.*-linux.*           libc=6
39
40 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
41 .*-.*-gnu-gnu.*         libmachuser=1
42
43 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
44 .*-.*-gnu-gnu*          libhurduser=0.0
45
46 # libc.so.0.2 is for the Hurd alpha release 0.2.
47 %ifdef USE_IN_LIBIO /* experimental only! */
48 .*-.*-gnu-gnu*          libc=0.2.90.libio       GLIBC_2.2
49 %else
50 .*-.*-gnu-gnu*          libc=0.2
51 %endif
52
53 # The dynamic loader also requires different names.
54 i.86-.*-linux.*         ld=ld-linux.so.2
55 sparc64-.*-linux.*      ld=ld-linux.so.2
56 sparc.*-.*-linux.*      ld=ld-linux.so.2
57 alpha.*-.*-linux.*      ld=ld-linux.so.2
58 arm.*-.*-linux.*        ld=ld-linux.so.2
59 sh.*-.*-linux.*         ld=ld-linux.so.2        GLIBC_2.2
60 ia64-.*-linux.*         ld=ld-linux-ia64.so.2   GLIBC_2.2
61 mips.*-.*-linux.*       ld=ld.so.1              GLIBC_2.0 GLIBC_2.2
62 # We use the ELF ABI standard name for the default.
63 .*-.*-.*                ld=ld.so.1
64
65 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
66 alpha.*-.*-linux.*      libdl=2.1
67 mips.*-.*-linux.*       libdl=2                 GLIBC_2.0 GLIBC_2.2
68 .*-.*-.*                libdl=2
69
70 # So far the -lutil interface is the same on all platforms, except for the
71 # `struct utmp' format, which depends on libc.
72 alpha.*-.*-linux.*      libutil=1.1
73 .*-.*-.*                libutil=1
74
75 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
76 # interface.
77 alpha.*-.*-linux.*      libresolv=2.1
78 mips.*-.*-linux.*       libresolv=2             GLIBC_2.0 GLIBC_2.2
79 .*-.*-.*                libresolv=2
80
81 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
82 # in nss/nsswitch.h, which determines the library names used for service
83 # names given in /etc/nsswitch.conf.
84 mips.*-.*-linux.*       libnss_files=2          GLIBC_2.0 GLIBC_2.2
85 mips.*-.*-linux.*       libnss_dns=2            GLIBC_2.0 GLIBC_2.2
86 mips.*-.*-linux.*       libnss_db=2             GLIBC_2.0 GLIBC_2.2
87 mips.*-.*-linux.*       libnss_compat=2         GLIBC_2.0 GLIBC_2.2
88 mips.*-.*-linux.*       libnss_nis=2            GLIBC_2.0 GLIBC_2.2
89 mips.*-.*-linux.*       libnss_nisplus=2        GLIBC_2.0 GLIBC_2.2
90 mips.*-.*-linux.*       libnss_ldap=2           GLIBC_2.0 GLIBC_2.2
91 mips.*-.*-linux.*       libnss_hesiod=2         GLIBC_2.0 GLIBC_2.2
92 .*-.*-.*                libnss_files=2
93 .*-.*-.*                libnss_dns=2
94 .*-.*-.*                libnss_db=2
95 .*-.*-.*                libnss_compat=2
96 .*-.*-.*                libnss_nis=2
97 .*-.*-.*                libnss_nisplus=2
98 .*-.*-.*                libnss_ldap=2
99 .*-.*-.*                libnss_hesiod=2
100
101 # Version for libnsl with YP and NIS+ functions.
102 alpha.*-.*-linux.*      libnsl=1.1
103 mips.*-.*-linux.*       libnsl=1                GLIBC_2.0 GLIBC_2.2
104 .*-.*-.*                libnsl=1
105
106 # We use libdb.so.3 for the interface in version 2.x of the Berkeley DB code.
107 .*-.*-.*                libdb=3
108 # This is the Berkeley DB 1.85.  We use the version numbers from glibc 2.0.*
109 # for all times.
110 alpha-.*-linux.*        libdb1=2.1
111 .*-.*-.*                libdb1=2
112
113 # This defines the shared library version numbers we will install.
114 alpha.*-.*-linux.*      libcrypt=1.1
115 .*-.*-.*                libcrypt=1
116
117 # The gross patch for programs assuming broken locale implementations.
118 alpha.*-.*-linux.*      libBrokenLocale=1.1
119 .*-.*-.*                libBrokenLocale=1
120
121 # The real-time library from POSIX.1b.
122 mips.*-.*-linux.*       librt=1                 GLIBC_2.0 GLIBC_2.2
123 .*-.*-.*                librt=1