Add libnss_nisplus.
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # Configuration         Library versions
9 # -------------         ------- --------
10
11 # The interface to -lm depends only on cpu, not on operating system.
12 i.86-.*-.*              libm=6
13 m68k-.*-.*              libm=6
14 alpha-.*-linux.*        libm=6.1
15 alpha-.*-.*             libm=6
16
17 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
18 i.86-.*-linux.*         libc=6
19 m68k-.*-linux.*         libc=6
20 alpha-.*-linux.*        libc=6.1
21
22 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
23 .*-.*-gnu-gnu.*         libmachuser=1
24
25 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
26 .*-.*-gnu-gnu*          libhurduser=0.0
27
28 # libc.so.0.2 is for the Hurd alpha release 0.2.
29 .*-.*-gnu-gnu*          libc=0.2
30
31 # The dynamic loader also requires different names.
32 i.86-.*-linux.*         ld=ld-linux.so.2
33 alpha-.*-linux.*        ld=ld-linux.so.2
34 # We use the ELF ABI standard name for the default.
35 .*-.*-.*                ld=ld.so.1
36
37 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
38 alpha-.*-linux.*        libdl=2.1
39 .*-.*-.*                libdl=2
40
41 # So far the -lutil interface is the same on all platforms, except for the
42 # `struct utmp' format, which depends on libc.
43 alpha-.*-linux.*        libutil=1.1
44 .*-.*-.*                libutil=1
45
46 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
47 # interface.
48 alpha-.*-linux.*        libresolv=2.1
49 .*-.*-.*                libresolv=2
50
51 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
52 # in nss/nsswitch.h, which determines the library names used for service
53 # names given in /etc/nsswitch.conf.
54 alpha-.*-linux.*        libnss_files=1.1
55 alpha-.*-linux.*        libnss_dns=1.1
56 alpha-.*-linux.*        libnss_db=1.1
57 alpha-.*-linux.*        libnss_compat=1.1
58 alpha-.*-linux.*        libnss_nis=1.1
59 alpha-.*-linux.*        libnss_nisplus=1.1
60 .*-.*-.*                libnss_files=1
61 .*-.*-.*                libnss_dns=1
62 .*-.*-.*                libnss_db=1
63 .*-.*-.*                libnss_compat=1
64 .*-.*-.*                libnss_nis=1
65 .*-.*-.*                libnss_nisplus=1
66
67 # Version for libnsl with YP and NIS+ functions.
68 alpha-.*-linux.*        libnsl=1.1
69 .*-.*-.*                libnsl=1
70
71 # We use libdb.so.2 for the interface in version 1.85 of the Berkeley DB code.
72 alpha-.*-linux.*        libdb=2.1
73 .*-.*-.*                libdb=2
74
75 # This defines the shared library version numbers we will install.
76 alpha-.*-linux.*        libcrypt=1.1
77 .*-.*-.*                libcrypt=1
78
79 # The gross patch for programs assuming broken locale implementations.
80 alpha-.*-linux.*        libBrokenLocale=1.1
81 .*-.*-.*                libBrokenLocale=1