update from main archive 961030
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # Configuration         Library versions
9 # -------------         ------- --------
10
11 # The interface to -lm depends only on cpu, not on operating system.
12 i?86-*-*                libm=6
13 m68k-*-*                libm=6
14 alpha-*-*               libm=6
15
16 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
17 i?86-*-linux*           libc=6
18 m68k-*-linux*           libc=6
19 alpha-*-linux*          libc=6
20
21 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
22 *-*-gnu?*               libmachuser=1
23
24 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
25 *-*-gnu?*               libhurduser=0.0
26
27 # libc.so.0.2 is for the Hurd alpha release 0.2.
28 *-*-gnu?*               libc=0.2
29
30 # The dynamic loader also requires different names.
31 i?86-*-linux*           ld=ld-linux.so.2
32 # We use the ELF ABI standard name for the default.
33 *-*-*                   ld=ld.so.1
34
35 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
36 *-*-*                   libdl=2
37
38 # So far the -lutil interface is the same on all platforms, except for the
39 # `struct utmp' format, which depends on libc.
40 *-*-*                   libutil=1
41
42 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
43 # interface.
44 *-*-*                   libresolv=2
45
46 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
47 # in nss/nsswitch.h, which determines the library names used for service
48 # names given in /etc/nsswitch.conf.
49 *-*-*                   libnss_files=1
50 *-*-*                   libnss_dns=1
51 *-*-*                   libnss_db=1
52
53 # We use libdb.so.2 for the interface in version 1.85 of the Berkeley DB code.
54 *-*-*                   libdb=2
55
56 # This defines the shared library version numbers we will install.
57 *-*-*                   libcrypt=1