Simplify libm entries. Correct a few Hurd entries.
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # This file can use cpp-style conditionals starting with % instead of #
9 # to test the symbols defined in config.h by configure.
10
11 # In the optional third column, there can one or more symbol set names
12 # listed, which must be in ascending version order reading left to right
13 # and must appear in this same order in the Versions.def file.  Each listed
14 # version subsumes all prior versions back to the previous listed version.
15
16 # Configuration         Library=version         Earliest symbol set (optional)
17 # -------------         ---------------         ------------------------------
18
19 # The interface to -lm depends mostly only on cpu, not on operating system.
20 sparc64-.*-linux.*      libm=6                  GLIBC_2.2
21 alpha.*-.*-linux.*      libm=6.1
22 mips.*-.*-linux.*       libm=6                  GLIBC_2.0 GLIBC_2.2
23 ia64-.*-linux.*         libm=6.1                GLIBC_2.2
24 sh.*-.*-linux.*         libm=6                  GLIBC_2.2
25 .*-.*-linux.*           libm=6
26 .*-.*-gnu-gnu.*         libm=6
27
28 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
29 alpha.*-.*-linux.*      libc=6.1
30 # Working mips versions were never released between 2.0 and 2.2.
31 mips.*-.*-linux.*       libc=6                  GLIBC_2.0 GLIBC_2.2
32 ia64-.*-linux.*         libc=6.1                GLIBC_2.2
33 sh.*-.*-linux.*         libc=6                  GLIBC_2.2
34 sparc64-.*-linux.*      libc=6                  GLIBC_2.2
35 .*-.*-linux.*           libc=6
36
37 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
38 .*-.*-gnu-gnu.*         libmachuser=1
39
40 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
41 .*-.*-gnu-gnu.*         libhurduser=0.0
42
43 # libc.so.0.2 is for the Hurd alpha release 0.2.
44 %ifdef USE_IN_LIBIO /* experimental only! */
45 .*-.*-gnu-gnu.*         libc=0.2.90.libio       GLIBC_2.2
46 %else
47 .*-.*-gnu-gnu.*         libc=0.2
48 %endif
49
50 # The dynamic loader also requires different names.
51 i.86-.*-linux.*         ld=ld-linux.so.2
52 sparc64-.*-linux.*      ld=ld-linux.so.2        GLIBC_2.2
53 sparc.*-.*-linux.*      ld=ld-linux.so.2
54 alpha.*-.*-linux.*      ld=ld-linux.so.2
55 arm.*-.*-linux.*        ld=ld-linux.so.2
56 sh.*-.*-linux.*         ld=ld-linux.so.2        GLIBC_2.2
57 ia64-.*-linux.*         ld=ld-linux-ia64.so.2   GLIBC_2.2
58 mips.*-.*-linux.*       ld=ld.so.1              GLIBC_2.0 GLIBC_2.2
59 # We use the ELF ABI standard name for the default.
60 .*-.*-.*                ld=ld.so.1
61
62 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
63 alpha.*-.*-linux.*      libdl=2.1
64 mips.*-.*-linux.*       libdl=2                 GLIBC_2.0 GLIBC_2.2
65 .*-.*-.*                libdl=2
66
67 # So far the -lutil interface is the same on all platforms, except for the
68 # `struct utmp' format, which depends on libc.
69 alpha.*-.*-linux.*      libutil=1.1
70 .*-.*-.*                libutil=1
71
72 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
73 # interface.
74 alpha.*-.*-linux.*      libresolv=2.1
75 mips.*-.*-linux.*       libresolv=2             GLIBC_2.0 GLIBC_2.2
76 .*-.*-.*                libresolv=2
77
78 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
79 # in nss/nsswitch.h, which determines the library names used for service
80 # names given in /etc/nsswitch.conf.
81 mips.*-.*-linux.*       libnss_files=2          GLIBC_2.0 GLIBC_2.2
82 mips.*-.*-linux.*       libnss_dns=2            GLIBC_2.0 GLIBC_2.2
83 mips.*-.*-linux.*       libnss_compat=2         GLIBC_2.0 GLIBC_2.2
84 mips.*-.*-linux.*       libnss_nis=2            GLIBC_2.0 GLIBC_2.2
85 mips.*-.*-linux.*       libnss_nisplus=2        GLIBC_2.0 GLIBC_2.2
86 mips.*-.*-linux.*       libnss_ldap=2           GLIBC_2.0 GLIBC_2.2
87 mips.*-.*-linux.*       libnss_hesiod=2         GLIBC_2.0 GLIBC_2.2
88 .*-.*-.*                libnss_files=2
89 .*-.*-.*                libnss_dns=2
90 .*-.*-.*                libnss_compat=2
91 .*-.*-.*                libnss_nis=2
92 .*-.*-.*                libnss_nisplus=2
93 .*-.*-.*                libnss_ldap=2
94 .*-.*-.*                libnss_hesiod=2
95
96 # Version for libnsl with YP and NIS+ functions.
97 alpha.*-.*-linux.*      libnsl=1.1
98 mips.*-.*-linux.*       libnsl=1                GLIBC_2.0 GLIBC_2.2
99 .*-.*-.*                libnsl=1
100
101 # This defines the shared library version numbers we will install.
102 alpha.*-.*-linux.*      libcrypt=1.1
103 .*-.*-.*                libcrypt=1
104
105 # The gross patch for programs assuming broken locale implementations.
106 alpha.*-.*-linux.*      libBrokenLocale=1.1
107 .*-.*-.*                libBrokenLocale=1
108
109 # The real-time library from POSIX.1b.
110 mips.*-.*-linux.*       librt=1                 GLIBC_2.0 GLIBC_2.2
111 .*-.*-.*                librt=1