2000-03-18 Roland McGrath <roland@baalperazim.frob.com>
[kopensolaris-gnu/glibc.git] / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # This file can use cpp-style conditionals starting with % instead of #
9 # to test the symbols defined in config.h by configure.
10
11 # Configuration         Library versions
12 # -------------         ------- --------
13
14 # The interface to -lm depends mostly only on cpu, not on operating system.
15 i.86-.*-.*              libm=6
16 m68k-.*-.*              libm=6
17 sparc.*-.*-.*           libm=6
18 alpha.*-.*-linux.*      libm=6.1
19 alpha.*-.*-.*           libm=6
20 powerpc-.*-.*           libm=6
21 mips.*-.*-.*            libm=6
22 arm.*-.*-.*             libm=6
23
24 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
25 alpha.*-.*-linux.*      libc=6.1
26 .*-.*-linux.*           libc=6
27
28 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
29 .*-.*-gnu-gnu.*         libmachuser=1
30
31 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
32 .*-.*-gnu-gnu*          libhurduser=0.0
33
34 # libc.so.0.2 is for the Hurd alpha release 0.2.
35 %ifdef USE_IN_LIBIO /* experimental only! */
36 .*-.*-gnu-gnu*          libc=0.2.90.libio
37 %else
38 .*-.*-gnu-gnu*          libc=0.2
39 %endif
40
41 # The dynamic loader also requires different names.
42 i.86-.*-linux.*         ld=ld-linux.so.2
43 sparc64-.*-linux.*      ld=ld-linux.so.2
44 sparc.*-.*-linux.*      ld=ld-linux.so.2
45 alpha.*-.*-linux.*      ld=ld-linux.so.2
46 arm.*-.*-linux.*        ld=ld-linux.so.2
47 # We use the ELF ABI standard name for the default.
48 .*-.*-.*                ld=ld.so.1
49
50 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
51 alpha.*-.*-linux.*      libdl=2.1
52 .*-.*-.*                libdl=2
53
54 # So far the -lutil interface is the same on all platforms, except for the
55 # `struct utmp' format, which depends on libc.
56 alpha.*-.*-linux.*      libutil=1.1
57 .*-.*-.*                libutil=1
58
59 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
60 # interface.
61 alpha.*-.*-linux.*      libresolv=2.1
62 .*-.*-.*                libresolv=2
63
64 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
65 # in nss/nsswitch.h, which determines the library names used for service
66 # names given in /etc/nsswitch.conf.
67 .*-.*-.*                libnss_files=2
68 .*-.*-.*                libnss_dns=2
69 .*-.*-.*                libnss_db=2
70 .*-.*-.*                libnss_compat=2
71 .*-.*-.*                libnss_nis=2
72 .*-.*-.*                libnss_nisplus=2
73 .*-.*-.*                libnss_ldap=2
74 .*-.*-.*                libnss_hesiod=2
75
76 # Version for libnsl with YP and NIS+ functions.
77 alpha.*-.*-linux.*      libnsl=1.1
78 .*-.*-.*                libnsl=1
79
80 # We use libdb.so.3 for the interface in version 2.x of the Berkeley DB code.
81 .*-.*-.*                libdb=3
82 # This is the Berkeley DB 1.85.  We use the version numbers from glibc 2.0.*
83 # for all times.
84 alpha-.*-linux.*        libdb1=2.1
85 .*-.*-.*                libdb1=2
86
87 # This defines the shared library version numbers we will install.
88 alpha.*-.*-linux.*      libcrypt=1.1
89 .*-.*-.*                libcrypt=1
90
91 # The gross patch for programs assuming broken locale implementations.
92 alpha.*-.*-linux.*      libBrokenLocale=1.1
93 .*-.*-.*                libBrokenLocale=1
94
95 # The real-time library from POSIX.1b.
96 .*-.*-.*                librt=1