Update.
[kopensolaris-gnu/glibc.git] / sysdeps / unix / sysv / linux / configure.in
1 sinclude(./aclocal.m4)dnl Autoconf lossage
2 GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
3 # Local configure fragment for sysdeps/unix/sysv/linux.
4
5 # On Linux, the default is to use libio instead of stdio.
6 test $stdio = default && stdio=libio
7
8 # Don't bother trying to generate any glue code to be compatible with the
9 # existing system library, because we are the only system library.
10 inhibit_glue=yes
11
12 define([LIBC_LINUX_VERSION],[2.0.10])dnl
13 if test -n "$sysheaders"; then
14   OLD_CPPFLAGS=$CPPFLAGS
15   CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
16 fi
17 define([libc_cv_linuxVER], [libc_cv_linux]patsubst(LIBC_LINUX_VERSION,[\.]))dnl
18 AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linuxVER, [dnl
19 AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
20 #if !defined LINUX_VERSION_CODE || LINUX_VERSION_CODE < ]dnl
21 patsubst(LIBC_LINUX_VERSION,[^\([^.]*\)\.\([^.]*\)\.\([^.]*\)$],dnl
22 [ (\1 *65536+ \2 *256+ \3) /* \1.\2.\3 */])[
23 eat flaming death
24 #endif],
25              libc_cv_linuxVER='TOO OLD!',
26              libc_cv_linuxVER='LIBC_LINUX_VERSION or later')])
27 if test "$libc_cv_linuxVER" != 'LIBC_LINUX_VERSION or later'; then
28   AC_MSG_ERROR([GNU libc requires kernel header files from
29 Linux LIBC_LINUX_VERSION or later to be installed before configuring.
30 The kernel header files are found usually in /usr/include/asm and
31 /usr/include/linux; make sure these directories use files from
32 Linux LIBC_LINUX_VERSION or later.  This check uses <linux/version.h>, so
33 make sure that file was built correctly when installing the kernel header
34 files.  To use kernel headers not from /usr/include/linux, use the
35 configure option --with-headers.])
36 fi
37
38 # If the user gave a minimal version number test whether the available
39 # kernel headers are young enough.  Additionally we have minimal
40 # kernel versions for some architectures.
41 case "$machine" in
42   alpha*)
43     arch_minimum_kernel=2.1.100
44     libc_cv_gcc_unwind_find_fde=yes
45     ;;
46   i386*)
47     libc_cv_gcc_unwind_find_fde=yes
48     arch_minimum_kernel=2.0.10
49     ;;
50   ia64*)
51     arch_minimum_kernel=2.4.0
52     ;;
53   hppa*)
54     arch_minimum_kernel=2.3.99
55     ;;
56   mips*)
57     arch_minimum_kernel=2.2.15
58     libc_cv_gcc_unwind_find_fde=yes
59     ;;
60   powerpc*)
61     libc_cv_gcc_unwind_find_fde=yes
62     arch_minimum_kernel=2.0.10
63     ;;
64   s390/s390-32)
65     libc_cv_gcc_unwind_find_fde=yes
66     arch_minimum_kernel=2.2.10
67     ;;
68   s390/s390-64)
69     libc_cv_gcc_unwind_find_fde=yes
70     arch_minimum_kernel=2.4.0
71     ;;
72   sh*)
73     arch_minimum_kernel=2.3.99
74     libc_cv_gcc_unwind_find_fde=yes
75     ;;
76   sparc*)
77     libc_cv_gcc_unwind_find_fde=yes
78     arch_minimum_kernel=2.0.10
79     ;;
80   x86_64*)
81     arch_minimum_kernel=2.4.0
82     ;;
83   *)
84     arch_minimum_kernel=2.0.10
85     ;;
86 esac
87 if test -n "$minimum_kernel"; then
88   changequote(,)
89   user_version=$((`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
90   arch_version=$((`echo "$arch_minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
91   changequote([,])
92   if test $user_version -lt $arch_version; then
93     AC_MSG_WARN([minimum kernel version reset to $arch_minimum_kernel])
94     minimum_kernel=$arch_minimum_kernel
95   fi
96 else
97   if test $arch_minimum_kernel != '2.0.10'; then
98     minimum_kernel=$arch_minimum_kernel
99   fi
100 fi
101
102 if test -n "$minimum_kernel"; then
103   AC_MSG_CHECKING(for kernel header at least $minimum_kernel)
104 changequote(,)dnl
105   decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
106   abinum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1,\2,\3/'`;
107 changequote([,])dnl
108   AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
109 #if LINUX_VERSION_CODE < $decnum
110 eat flaming death
111 #endif], libc_minimum_kernel='too old!', libc_minimum_kernel=ok)
112   AC_MSG_RESULT($libc_minimum_kernel)
113   if test "$libc_minimum_kernel" = ok; then
114     AC_DEFINE_UNQUOTED(__LINUX_KERNEL_VERSION, $decnum)
115     AC_DEFINE_UNQUOTED(__ABI_TAG_VERSION, $abinum)
116   else
117     AC_MSG_ERROR([*** The available kernel headers are older than the requested
118 *** compatible kernel version])
119   fi
120 fi
121
122 # The result of the above test for the use of the FDE code is invalid if
123 # the user overrides the decision about the minimum ABI.
124 if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then
125   libc_cv_gcc_unwind_find_fde=no
126 fi
127
128 if test -n "$sysheaders"; then
129   CPPFLAGS=$OLD_CPPFLAGS
130 fi
131 # The Linux filesystem standard prescribes where to place "essential"
132 # files.  I.e., when the installation prefix is "/usr" we have to place
133 # shared library objects and the configuration files on the root partition
134 # in /lib and /etc.
135 if test "$prefix" = "/usr" -o "$prefix" = "/usr/"; then
136   # 64bit libraries on sparc go to /lib64 and not /lib
137   if test "$machine" = "sparc/sparc64" -o "$machine" = "x86_64"; then
138     libc_cv_slibdir="/lib64"
139     if test "$libdir" = '${exec_prefix}/lib'; then
140       libdir='${exec_prefix}/lib64';
141       # Locale data can be shared between 32bit and 64bit libraries
142       libc_cv_localedir='${exec_prefix}/lib/locale'
143     fi
144   else
145     libc_cv_slibdir="/lib"
146   fi
147   # Allow the user to override the path with --sysconfdir
148   if test $sysconfdir = '${prefix}/etc'; then
149     libc_cv_sysconfdir=/etc
150   else
151     libc_cv_sysconfdir=$sysconfdir
152    fi
153   libc_cv_rootsbindir="/sbin"
154 fi
155
156 # Under Linux the LinuxThreads add-on should be available.
157 case $add_ons in
158   # It is available.  Good.
159   *linuxthreads*)
160     linuxthreads_missing=
161     ;;
162   *)
163     linuxthreads_missing=yes
164     ;;
165 esac
166
167 if test "$linuxthreads_missing"; then
168   if test $enable_sanity = yes; then
169     echo "\
170 *** On GNU/Linux systems it is normal to compile GNU libc with the
171 *** \`linuxthreads' add-on.  Without that, the library will be
172 *** incompatible with normal GNU/Linux systems.
173 *** If you really mean to not use this add-on, run configure again
174 *** using the extra parameter \`--disable-sanity-checks'."
175     exit 1
176   else
177     echo "\
178 *** WARNING: Are you sure you do not want to use the \`linuxthreads'
179 *** add-on?"
180   fi
181 fi
182
183 # One Linux we use ldconfig.
184 use_ldconfig=yes
185
186 # We need some extensions to the `ldd' script.
187 changequote(,)
188 case "$machine" in
189   i[3456]86* | m68*)
190     ldd_rewrite_script=../sysdeps/unix/sysv/linux/ldd-rewrite.sed
191     ;;
192   ia64*)
193     ldd_rewrite_script=../sysdeps/unix/sysv/linux/ia64/ldd-rewrite.sed
194     ;;
195   s390*)
196     ldd_rewrite_script=../sysdeps/unix/sysv/linux/s390/ldd-rewrite.sed
197     ;;
198   sparc*)
199     ldd_rewrite_script=../sysdeps/unix/sysv/linux/sparc/ldd-rewrite.sed
200     ;;
201   x86_64*)
202     ldd_rewrite_script=../sysdeps/unix/sysv/linux/x86_64/ldd-rewrite.sed
203     ;;
204   *)
205     ;;
206 esac
207 changequote([,])
208
209 if test $host = $build; then
210   # If $prefix/include/{net,scsi} are symlinks, make install will
211   # clobber what they're linked to (probably a kernel tree).
212   # test -L ought to work on all Linux boxes.
213   if test "x$prefix" != xNONE; then
214     ac_prefix=$prefix
215   else
216     ac_prefix=$ac_default_prefix
217   fi
218   AC_MSG_CHECKING([for symlinks in ${ac_prefix}/include])
219   ac_message=
220   if test -L ${ac_prefix}/include/net; then
221     ac_message="$ac_message
222    ${ac_prefix}/include/net is a symlink"
223   fi
224   if test -L ${ac_prefix}/include/scsi; then
225     ac_message="$ac_message
226    ${ac_prefix}/include/scsi is a symlink"
227   fi
228   if test -n "$ac_message"; then
229     AC_MSG_ERROR([$ac_message
230 \`make install' will destroy the target of the link(s).
231 Delete the links and re-run configure, or better still, move the entire
232 ${ac_prefix}/include directory out of the way.])
233   else
234     AC_MSG_RESULT(ok)
235   fi
236 fi