* sysdeps/unix/sysv/linux/configure.in: Add check for minimal
[kopensolaris-gnu/glibc.git] / sysdeps / unix / sysv / linux / configure
1  # Local configure fragment for sysdeps/unix/sysv/linux.
2
3 # On Linux, the default is to use libio instead of stdio.
4 test $stdio = default && stdio=libio
5
6 # Don't bother trying to generate any glue code to be compatible with the
7 # existing system library, because we are the only system library.
8 inhibit_glue=yes
9
10 if test -n "$sysheaders"; then
11   OLD_CPPFLAGS=$CPPFLAGS
12   CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
13 fi
14 echo $ac_n "checking installed Linux kernel header files""... $ac_c" 1>&6
15 echo "configure:16: checking installed Linux kernel header files" >&5
16 if eval "test \"`echo '$''{'libc_cv_linux2010'+set}'`\" = set"; then
17   echo $ac_n "(cached) $ac_c" 1>&6
18 else
19   cat > conftest.$ac_ext <<EOF
20 #line 21 "configure"
21 #include "confdefs.h"
22 #include <linux/version.h>
23 #if !defined LINUX_VERSION_CODE || LINUX_VERSION_CODE <  (2 *65536+ 0 *256+ 10) /* 2.0.10 */
24 eat flaming death
25 #endif
26 EOF
27 if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
28   egrep "eat flaming death" >/dev/null 2>&1; then
29   rm -rf conftest*
30   libc_cv_linux2010='TOO OLD!'
31 else
32   rm -rf conftest*
33   libc_cv_linux2010='2.0.10 or later'
34 fi
35 rm -f conftest*
36
37 fi
38
39 echo "$ac_t""$libc_cv_linux2010" 1>&6
40 if test "$libc_cv_linux2010" != '2.0.10 or later'; then
41   { echo "configure: error: GNU libc requires kernel header files from
42 Linux 2.0.10 or later to be installed before configuring.
43 The kernel header files are found usually in /usr/include/asm and
44 /usr/include/linux; make sure these directories use files from
45 Linux 2.0.10 or later.  This check uses <linux/version.h>, so
46 make sure that file was built correctly when installing the kernel header
47 files.  To use kernel headers not from /usr/include/linux, use the
48 configure option --with-headers." 1>&2; exit 1; }
49 fi
50
51 # If the user gave a minimal version number test whether the available
52 # kernel headers are young enough.  Additionally we have minimal
53 # kernel versions for some architectures.
54 case "$machine" in
55   mips*)
56     arch_minimum_kernel=2.2.15
57     ;;
58   sh*)
59     arch_minimum_kernel=2.3.99
60     ;;
61   ia64*)
62     arch_minimum_kernel=2.4.0
63     ;;
64   *)
65     arch_minimum_kernel=2.0.10
66     ;;
67 esac
68 if test -n "$minimum_kernel"; then
69   
70   user_version=$((`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
71   arch_version=$((`echo "$arch_minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
72   
73   if test $user_version -lt $arch_version; then
74     echo "configure: warning: minimum kernel version reset to $arch_minimum_kernel" 1>&2
75     minimum_kernel=$arch_minimum_kernel
76   fi
77 else
78   if test $arch_minimum_kernel != '2.0.10'; then
79     minimum_kernel=$arch_minimum_kernel
80   fi
81 fi
82
83 if test -n "$minimum_kernel"; then
84   echo $ac_n "checking for kernel header at least $minimum_kernel""... $ac_c" 1>&6
85 echo "configure:86: checking for kernel header at least $minimum_kernel" >&5
86   decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
87   cat > conftest.$ac_ext <<EOF
88 #line 89 "configure"
89 #include "confdefs.h"
90 #include <linux/version.h>
91 #if LINUX_VERSION_CODE < $decnum
92 eat flaming death
93 #endif
94 EOF
95 if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
96   egrep "eat flaming death" >/dev/null 2>&1; then
97   rm -rf conftest*
98   libc_minimum_kernel='too old!'
99 else
100   rm -rf conftest*
101   libc_minimum_kernel=ok
102 fi
103 rm -f conftest*
104
105   echo "$ac_t""$libc_minimum_kernel" 1>&6
106   if test "$libc_minimum_kernel" = ok; then
107     cat >> confdefs.h <<EOF
108 #define __LINUX_KERNEL_VERSION $decnum
109 EOF
110
111   else
112     { echo "configure: error: *** The available kernel headers are older than the requested
113 *** compatible kernel version" 1>&2; exit 1; }
114   fi
115 fi
116
117 if test -n "$sysheaders"; then
118   CPPFLAGS=$OLD_CPPFLAGS
119 fi
120 # The Linux filesystem standard prescribes where to place "essential"
121 # files.  I.e., when the installation prefix is "/usr" we have to place
122 # shared library objects and the configuration files on the root partition
123 # in /lib and /etc.
124 if test "$prefix" = "/usr" -o "$prefix" = "/usr/"; then
125   # 64bit libraries on sparc go to /lib64 and not /lib
126   if test "$machine" = "sparc/sparc64"; then
127     libc_cv_slibdir="/lib64"
128     if test "$libdir" = '${exec_prefix}/lib'; then
129       libdir='${exec_prefix}/lib64';
130       # Locale data can be shared between 32bit and 64bit libraries
131       libc_cv_localedir='${exec_prefix}/lib/locale'
132     fi
133   else
134     libc_cv_slibdir="/lib"
135   fi
136   # Allow the user to override the path with --sysconfdir
137   if test $sysconfdir = '${prefix}/etc'; then
138     libc_cv_sysconfdir=/etc
139   else
140     libc_cv_sysconfdir=$sysconfdir
141    fi
142   libc_cv_rootsbindir="/sbin"
143 fi
144
145 # Under Linux the LinuxThreads add-on should be available.
146 case $add_ons in
147   # It is available.  Good.
148   *linuxthreads*)
149     message=
150     ;;
151   *)
152     message="\
153 *** WARNING: Are you sure you do not want to use the \`linuxthreads'
154 *** add-on?"
155     ;;
156 esac
157
158 if test "$message"; then
159   if test $enable_sanity = yes; then
160     echo "\
161 *** You should not compile the GNU libc without the \`linuxthreads'
162 *** add-on.  Not using them risks being incompatible with the
163 *** libraries of other systems.  Consider getting the add-on and restarting
164 *** the configuration.
165 *** If you really mean to not use this add-on, run configure again
166 *** using the extra parameter \`--disable-sanity-checks'."
167     exit 1
168   else
169     echo "$message"
170   fi
171 fi
172
173 # One Linux we use ldconfig.
174 use_ldconfig=yes
175
176 # We need some extensions to the `ldd' script.
177
178 case "$machine" in
179   i[3456]86* | m68*)
180     ldd_rewrite_script=../sysdeps/unix/sysv/linux/ldd-rewrite.sed
181     ;;
182   sparc*)
183     ldd_rewrite_script=../sysdeps/unix/sysv/linux/sparc/ldd-rewrite.sed
184     ;;
185   *)
186     ;;
187 esac
188
189
190 if test $host = $build; then
191   # If $prefix/include/{net,scsi} are symlinks, make install will
192   # clobber what they're linked to (probably a kernel tree).
193   # test -L ought to work on all Linux boxes.
194   if test "x$prefix" != xNONE; then
195     ac_prefix=$prefix
196   else
197     ac_prefix=$ac_default_prefix
198   fi
199   echo $ac_n "checking for symlinks in ${ac_prefix}/include""... $ac_c" 1>&6
200 echo "configure:201: checking for symlinks in ${ac_prefix}/include" >&5
201   ac_message=
202   if test -L ${ac_prefix}/include/net; then
203     ac_message="$ac_message
204    ${ac_prefix}/include/net is a symlink"
205   fi
206   if test -L ${ac_prefix}/include/scsi; then
207     ac_message="$ac_message
208    ${ac_prefix}/include/scsi is a symlink"
209   fi
210   if test -n "$ac_message"; then
211     { echo "configure: error: $ac_message
212 \`make install' will destroy the target of the link(s).
213 Delete the links and re-run configure, or better still, move the entire
214 ${ac_prefix}/include directory out of the way." 1>&2; exit 1; }
215   else
216     echo "$ac_t""ok" 1>&6
217   fi
218 fi