configure script for Solaris.
[kopensolaris-gnu/glibc.git] / sysdeps / unix / sysv / sysv4 / solaris2 / configure.in
1 sinclude(./aclocal.m4)dnl Autoconf lossage
2 GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
3 # Local configure fragment for sysdeps/unix/sysv/sysv4/solaris2
4
5 # Concensus on stdio is that it's broken.
6 test $stdio = default && stdio=libio
7
8 # Crypt is your friend.
9 case $add_ons in
10   *crypt*)
11     message=
12     ;;
13   *)
14     message="\
15 *** WARNING:
16 *** Are you sure you do not want to use the \`crypt' add-on?"
17     ;;
18 esac
19
20 if test "$message"; then
21   if test $enable_sanity = yes; then
22     echo "\
23 *** You should not compile the GNU libc without the \`crypt' add-on.
24 *** Not using them risks to be incompatible with the libraries of
25 *** other systems.  Consider getting the add-on and restart the
26 *** configuration.
27 *** If you reall mean to avoid this add-on run configure again, now
28 *** using the extra parameter \`--disable-sanity-checks'."
29     exit 1
30   else
31     echo "$message"
32   fi
33 fi