Use MAP_ANON instead of MAP_ANONYMOUS.
[kopensolaris-gnu/glibc.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index 410c21c..276750a 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -247,7 +247,7 @@ build the GNU C library:
      bugs which only show up in big projects like GNU `libc'.  Version
      3.76.1 seems OK but some people have reported problems.
 
-   * EGCS 1.1 or 1.0.3
+   * EGCS 1.1.1, 1.1 or 1.0.3
 
      The GNU C library can only be compiled with the GNU C compiler
      family.  We recommend EGCS 1.0.3 or higher.  GCC 2.8.1 and older
@@ -257,7 +257,13 @@ build the GNU C library:
      libc, but you may have problems, particularly with the math
      functions.)
 
-   * GNU `binutils' 2.8.1.0.23, 2.9.1, or 2.9.0.15
+     On Alpha machines you need at least EGCS 1.1.1.  Earlier versions
+     don't work reliably.
+
+     For PPC you might need some patches even on top of the last EGCS
+     version.  See the FAQ.
+
+   * GNU `binutils' 2.9.1, or 2.9.1.0.16
 
      You must use GNU binutils (as and ld) if you want to build a shared
      library.  Even if you don't, we recommend you use them anyway.  No
@@ -265,8 +271,12 @@ build the GNU C library:
 
      The quality of binutils releases has varied a bit recently.  The
      bugs are in obscure features, but glibc uses quite a few of those.
-     2.8.1.0.23, 2.9.1, and 2.9.0.15 are known to work.  Versions after
-     2.8.1.0.23 may or may not work.  Older versions definitely don't.
+     2.9.1 and 2.9.1.0.16 are known to work.  Versions after 2.8.1.0.23
+     may or may not work.  Older versions definitely don't.  2.9.1.0.16
+     is required on some platforms, like PPC and Arm.
+
+     For PPC you might need some patches even on top of the last
+     binutils version.  See the FAQ.
 
    * GNU `texinfo' 3.11
 
@@ -305,6 +315,7 @@ Supported Configurations
 following patterns:
 
      alpha-*-linux
+     arm-*-linux
      arm-*-linuxaout
      arm-*-none
      iX86-*-gnu