Standardize the multiple-include protect.
[kopensolaris-gnu/glibc.git] / config.h.in
index 52332be..390b228 100644 (file)
@@ -4,12 +4,19 @@
 #undef HAVE_GNU_LD
 
 /* Define if using ELF, which supports weak symbols.
-   This implies HAVE_WEAK_SYMBOLS; set by --with-elf.  */
+   This implies HAVE_ASM_WEAK_DIRECTIVE and NO_UNDERSCORES; set by
+   --with-elf.  */
 #undef HAVE_ELF
 
-/* Define if weak symbols are available in the assembler and
-   linker being used.  Set by --with-weak-symbols.  */
-#undef HAVE_WEAK_SYMBOLS
+/* Define if C symbols are asm symbols.  Don't define if C symbols
+   have a `_' prepended to make the asm symbol.  */
+#undef NO_UNDERSCORES
+
+/* Define if weak symbols are available via the `.weak' directive.  */
+#undef HAVE_ASM_WEAK_DIRECTIVE
+
+/* Define if weak symbols are available via the `.weakext' directive.  */
+#undef HAVE_ASM_WEAKEXT_DIRECTIVE
 
 /* Define if not using ELF, but `.init' and `.fini' sections are available.  */
 #undef HAVE_INITFINI
    declaring a symbol global (default `.globl').  */
 #undef ASM_GLOBAL_DIRECTIVE
 
-/* ELF has weak symbols, and with GNU ld a.out does too.  */
-#ifndef HAVE_WEAK_SYMBOLS
-#if defined (HAVE_ELF) || defined (HAVE_GNU_LD)
-#define HAVE_WEAK_SYMBOLS
-#endif
-#endif
-
 /* Define to use GNU libio instead of GNU stdio.
    This is defined by configure under --enable-libio.  */
 #undef USE_IN_LIBIO
 
+/* Define if using ELF and the assembler supports the `.previous'
+   directive.  */
+#undef HAVE_ASM_PREVIOUS_DIRECTIVE
+
+/* Define if using ELF and the assembler supports the `.popsection'
+   directive.  */
+#undef HAVE_ASM_POPSECTION_DIRECTIVE
+
+/* Define if versioning of the library is wanted.  */
+#undef DO_VERSIONING
+
+/* Define if static NSS modules are wanted.  */
+#undef DO_STATIC_NSS
+
 /*
 \f */
 
@@ -71,4 +85,8 @@
 
 #define        HAVE_STRERROR   1
 
+/* The locale code needs these definitions.  */
+
+#define HAVE_REGEX 1
+
 #endif