Use correct comment character.
[kopensolaris-gnu/glibc.git] / shlib-versions
index 3518610..24e934d 100644 (file)
 # -------------                ---------------         ------------------------------
 
 # The interface to -lm depends mostly only on cpu, not on operating system.
-i.86-.*-.*             libm=6
-m68k-.*-.*             libm=6
 sparc64-.*-linux.*     libm=6                  GLIBC_2.2
-sparc.*-.*-.*          libm=6
 alpha.*-.*-linux.*     libm=6.1
-alpha.*-.*-.*          libm=6
-powerpc-.*-.*          libm=6
 mips.*-.*-linux.*      libm=6                  GLIBC_2.0 GLIBC_2.2
-mips.*-.*-.*           libm=6
-arm.*-.*-.*            libm=6
-ia64-.*-.*             libm=6.1                GLIBC_2.2
-sh.*-.*-.*             libm=6                  GLIBC_2.2
+ia64-.*-linux.*                libm=6.1                GLIBC_2.2
+sh.*-.*-linux.*                libm=6                  GLIBC_2.2
+hppa.*-.*-.*           libm=6                  GLIBC_2.2
+.*-.*-linux.*          libm=6
+.*-.*-gnu-gnu.*                libm=6
 
 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
 alpha.*-.*-linux.*     libc=6.1
 # Working mips versions were never released between 2.0 and 2.2.
 mips.*-.*-linux.*      libc=6                  GLIBC_2.0 GLIBC_2.2
-ia64-.*-.*             libc=6.1                GLIBC_2.2
-sh.*-.*-.*              libc=6                  GLIBC_2.2
+ia64-.*-linux.*                libc=6.1                GLIBC_2.2
+sh.*-.*-linux.*                libc=6                  GLIBC_2.2
 sparc64-.*-linux.*     libc=6                  GLIBC_2.2
+hppa.*-.*-.*           libc=6                  GLIBC_2.2
 .*-.*-linux.*          libc=6
 
 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
 .*-.*-gnu-gnu.*                libmachuser=1
 
 # libhurduser.so.0.0 corresponds to hurd/*.defs as of 7 May 1996.
-.*-.*-gnu-gnu*         libhurduser=0.0
+.*-.*-gnu-gnu.*                libhurduser=0.0
 
 # libc.so.0.2 is for the Hurd alpha release 0.2.
 %ifdef USE_IN_LIBIO /* experimental only! */
-.*-.*-gnu-gnu*         libc=0.2.90.libio       GLIBC_2.2
+.*-.*-gnu-gnu.*                libc=0.2.90.libio       GLIBC_2.2
 %else
-.*-.*-gnu-gnu*         libc=0.2
+.*-.*-gnu-gnu.*                libc=0.2
 %endif
 
 # The dynamic loader also requires different names.
@@ -61,6 +58,7 @@ arm.*-.*-linux.*      ld=ld-linux.so.2
 sh.*-.*-linux.*                ld=ld-linux.so.2        GLIBC_2.2
 ia64-.*-linux.*                ld=ld-linux-ia64.so.2   GLIBC_2.2
 mips.*-.*-linux.*      ld=ld.so.1              GLIBC_2.0 GLIBC_2.2
+hppa.*-.*-.*           ld=ld.so.1              GLIBC_2.2
 # We use the ELF ABI standard name for the default.
 .*-.*-.*               ld=ld.so.1
 
@@ -85,7 +83,6 @@ mips.*-.*-linux.*     libresolv=2             GLIBC_2.0 GLIBC_2.2
 # names given in /etc/nsswitch.conf.
 mips.*-.*-linux.*      libnss_files=2          GLIBC_2.0 GLIBC_2.2
 mips.*-.*-linux.*      libnss_dns=2            GLIBC_2.0 GLIBC_2.2
-mips.*-.*-linux.*      libnss_db=2             GLIBC_2.0 GLIBC_2.2
 mips.*-.*-linux.*      libnss_compat=2         GLIBC_2.0 GLIBC_2.2
 mips.*-.*-linux.*      libnss_nis=2            GLIBC_2.0 GLIBC_2.2
 mips.*-.*-linux.*      libnss_nisplus=2        GLIBC_2.0 GLIBC_2.2
@@ -93,7 +90,6 @@ mips.*-.*-linux.*     libnss_ldap=2           GLIBC_2.0 GLIBC_2.2
 mips.*-.*-linux.*      libnss_hesiod=2         GLIBC_2.0 GLIBC_2.2
 .*-.*-.*               libnss_files=2
 .*-.*-.*               libnss_dns=2
-.*-.*-.*               libnss_db=2
 .*-.*-.*               libnss_compat=2
 .*-.*-.*               libnss_nis=2
 .*-.*-.*               libnss_nisplus=2
@@ -105,19 +101,16 @@ alpha.*-.*-linux.*        libnsl=1.1
 mips.*-.*-linux.*      libnsl=1                GLIBC_2.0 GLIBC_2.2
 .*-.*-.*               libnsl=1
 
-# We use libdb.so.3 for the interface in version 2.x of the Berkeley DB code.
-.*-.*-.*               libdb=3
-# This is the Berkeley DB 1.85.  We use the version numbers from glibc 2.0.*
-# for all times.
-alpha-.*-linux.*        libdb1=2.1
-.*-.*-.*                libdb1=2
-
 # This defines the shared library version numbers we will install.
 alpha.*-.*-linux.*     libcrypt=1.1
 .*-.*-.*               libcrypt=1
 
 # The gross patch for programs assuming broken locale implementations.
 alpha.*-.*-linux.*     libBrokenLocale=1.1
+ia64-.*-.*             libBrokenLocale=1       GLIBC_2.2
+sh.*-.*-.*             libBrokenLocale=1       GLIBC_2.2
+sparc64-.*-.*          libBrokenLocale=1       GLIBC_2.2
+hppa-.*-.*             libBrokenLocale=1       GLIBC_2.2
 .*-.*-.*               libBrokenLocale=1
 
 # The real-time library from POSIX.1b.