(libc): Add #errlist-compat comments at GLIBC_2.0, GLIBC_2.1 and GLIBC_2.3.
[kopensolaris-gnu/glibc.git] / sysdeps / unix / sysv / linux / alpha / Versions
index c18816c..89ec9db 100644 (file)
@@ -1,5 +1,14 @@
 libc {
+  # The comment lines with "#errlist-compat" are magic; see
+  # sysdeps/gnu/errlist-compat.awk.
+  # When you get an error from errlist-compat.awk, you need to add a new
+  # version here.  Don't do this blindly, since this means changing the ABI
+  # for all GNU/Linux configurations.
+
   GLIBC_2.0 {
+    #errlist-compat    131
+    _sys_errlist; sys_errlist; _sys_nerr; sys_nerr;
+
     # Unfortunately in wider use.
     _inb; _inw; _inl; _outb; _outw; _outl; _bus_base; _bus_base_sparse;
     _hae_shift;
@@ -24,6 +33,9 @@ libc {
     pciconfig_read; pciconfig_write; sethae;
   }
   GLIBC_2.1 {
+    #errlist-compat    131
+    _sys_errlist; sys_errlist; _sys_nerr; sys_nerr;
+
     # Linux/Alpha 64-bit timeval functions.
     __select; select;
     adjtime; adjtimex; __adjtimex;
@@ -57,4 +69,14 @@ libc {
     # w*
     wordexp;
   }
+  GLIBC_2.3 {
+    #errlist-compat    132
+    _sys_errlist; sys_errlist; _sys_nerr; sys_nerr;
+  }
+}
+librt {
+  GLIBC_2.3 {
+    # AIO functions.
+    aio_cancel; aio_cancel64;
+  }
 }