Update gcc requirement
authordrepper <drepper>
Sat, 18 Nov 2000 17:45:00 +0000 (17:45 +0000)
committerdrepper <drepper>
Sat, 18 Nov 2000 17:45:00 +0000 (17:45 +0000)
FAQ.in

diff --git a/FAQ.in b/FAQ.in
index 2a87a6d..2daeea9 100644 (file)
--- a/FAQ.in
+++ b/FAQ.in
@@ -63,22 +63,9 @@ a local mirror first.
 
 You should always try to use the latest official release.  Older versions
 may not have all the features GNU libc requires.  The current releases of
-egcs (1.0.3 and 1.1.1) should work with the GNU C library (for powerpc see
+gcc (2.95 or newer) should work with the GNU C library (for powerpc see
 ?powerpc; for ARM see ?arm; for MIPS see ?mips).
 
-While the GNU CC should be able to compile glibc it is nevertheless adviced
-to use EGCS.  Comparing the sizes of glibc on Intel compiled with a recent
-EGCS and gcc 2.8.1 shows this:
-
-                 text    data     bss     dec     hex filename
-   egcs-2.93.10        862897   15944   12824  891665   d9b11 libc.so
-   gcc-2.8.1   959965   16468   12152  988585   f15a9 libc.so
-
-Make up your own decision.
-
-GNU CC versions 2.95 and above are derived from egcs, and they may do even
-better.
-
 Please note that gcc 2.95 and 2.95.x cannot compile glibc on Alpha due to
 problems in the complex float support.
 
@@ -193,11 +180,7 @@ to the root of the 2.2 tree and do `make include/linux/version.h'.
 ??     The compiler hangs while building iconvdata modules.  What's
        wrong?
 
-{ZW} This is a problem with old versions of GCC.  Initialization of large
-static arrays is very slow.  The compiler will eventually finish; give it
-time.
-
-The problem is fixed in egcs 1.1.
+{} Removed.  Does not apply anymore.
 
 ??     When I run `nm -u libc.so' on the produced library I still
        find unresolved symbols.  Can this be ok?
@@ -643,8 +626,7 @@ you got with your distribution.
        glibc 2.x?
 
 {AJ} There's only correct support for glibc 2.0.x in gcc 2.7.2.3 or later.
-But you should get at least gcc 2.8.1 or egcs 1.1 (or later versions)
-instead.
+But you should get at least gcc 2.95.2 (or later versions) instead.
 
 ??     The `gencat' utility cannot process the catalog sources which
        were used on my Linux libc5 based system.  Why?