Remove prehistoric comment about nscd incompatibility with 2.0 kernels.