(sysdeps_routines): Use libgcc-compat instead of cmpdi2, shdi3, fixdfdi,