* config.sub: Recognize gnu-gnu* along with linux-gnu* as a valid