Avoid using PHP for the expired sites