Tue Jul 9 06:19:29 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>
authorroland <roland>
Tue, 9 Jul 1996 12:22:05 +0000 (12:22 +0000)
committerroland <roland>
Tue, 9 Jul 1996 12:22:05 +0000 (12:22 +0000)
* sysdeps/unix/sysv/linux/configure.in: Use version number in cache
  variable name, so new a libc with new requirements won't fail to
  notice an insufficient Linux version.

sysdeps/unix/sysv/linux/configure.in

index 21079a3..15637fa 100644 (file)
@@ -9,14 +9,14 @@ test $stdio = default && stdio=libio
 # existing system library, because we are the only system library.
 inhibit_glue=yes
 
-AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linux, [dnl
+AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linux201, [dnl
 AC_TRY_COMPILE([#include <linux/version.h>],
 [#if LINUX_VERSION_CODE < (2 *65536+ 0 *256+ 1) /* 2.0.1 */
 eat flaming death
 #endif],
-              libc_cv_linux='2.0.1 or later',
-              libc_cv_linux='TOO OLD!')])
-if test "$libc_cv_linux" != '2.0.1 or later'; then
+              libc_cv_linux201='2.0.1 or later',
+              libc_cv_linux201='TOO OLD!')])
+if test "$libc_cv_linux201" != '2.0.1 or later'; then
   AC_MSG_ERROR([GNU libc requires kernel header files from Linux 2.0.1
 or later to be installed before configuring.  The kernel header files
 are found usually in /usr/include/asm and /usr/include/linux; make sure