Move back to package-lock v2 (#176)

Also adds a CI step to ensure that we're not merging lockfile v1.

Reviewed-on: www/www-new#176
Co-authored-by: Aditya Thakral <a3thakra@csclub.uwaterloo.ca>
Co-committed-by: Aditya Thakral <a3thakra@csclub.uwaterloo.ca>
fix-md-font
Aditya Thakral 1 year ago
parent 72709f5d6e
commit b6d0544e3e
  1. 7
      .drone.yml
  2. 10
      check-lockfile.js
  3. 9089
      package-lock.json

@ -4,8 +4,15 @@ type: docker
name: node16
steps:
- name: check-lockfile
image: node:16
commands:
- node ./check-lockfile.js
- name: install-deps
image: node:16
depends_on:
- check-lockfile
commands:
- npm install

@ -0,0 +1,10 @@
const lockfile = require('./package-lock.json')
if (lockfile.lockfileVersion !== 2) {
console.error(`
Please upgrade to npm v7 and revert changes to the lockfile.
- \`npm i -g npm\` to upgrade.
`.trim())
process.exit(1)
}

9089
package-lock.json generated

File diff suppressed because it is too large Load Diff
Loading…
Cancel
Save