Changes used for installing buster on neotame and mannitol

v2-neotame-mannitol
bandali 3 years ago
parent 16e7cc76d6
commit 5531605a1b
  1. 11
      hosts
  2. 42
      roles/devel/tasks/main.yml
  3. 4
      roles/general-use/tasks/main.yml

11
hosts

@ -2,14 +2,9 @@ test:
children:
debian:
hosts:
172.19.134.64: {}
172.19.134.54: {}
neotame: {}
mannitol: {}
vars:
ansible_user: debian
ubuntu:
hosts:
172.19.134.38: {}
vars:
ansible_user: ubuntu
ansible_user: root
vars:
ansible_ssh_private_key_file: ~/.ssh/id_rsa

@ -29,12 +29,12 @@
- pbuilder
- dpkg-repack
- name: Install kernel-package (not Debian Stretch)
when: not(ansible_distribution == 'Debian' and ansible_distribution_release == 'stretch')
apt:
name: kernel-package
state: present
cache_valid_time: 3600
#- name: Install kernel-package (not Debian Stretch)
# when: not(ansible_distribution == 'Debian' and ansible_distribution_release == 'stretch')
# apt:
# name: kernel-package
# state: present
# cache_valid_time: 3600
- name: Configure dupload
file:
@ -95,8 +95,8 @@
cache_valid_time: 3600
with_items:
- manpages-dev
- gcc-doc
- cpp-doc
# - gcc-doc
# - cpp-doc
- binutils-doc
- manpages-posix-dev
- glibc-doc
@ -128,18 +128,18 @@
- ghc
- ghc-doc
- haskell-platform
- openjdk-8-jdk-headless
- openjdk-11-jdk-headless
- mono-complete
- mono-devel
- mono-profiler
- mono-tools-devel
- mono-tools-gui
- mono-vbnc
# - mono-vbnc
- ocaml
- camlp4
- lua5.3
- liblua5.3-dev
- php7.0-cli
- php7.3-cli
- name: Install scheme/racket
apt:
@ -252,7 +252,8 @@
- pyflakes
- python-m2crypto
- python-mysqldb
- python-imaging
# - python-imaging
- python-pil
- python-libxml2
- python-libxslt1
- python-numpy
@ -266,7 +267,8 @@
- python-subversion
- python-urwid
- python-xmpp
- python-beautifulsoup
# - python-beautifulsoup
- python3-bs4
- python-chardet
- python-kerberos
- python-mako
@ -298,7 +300,7 @@
with_items:
- tcl
- tcl-dev
- tcl8.5
- tcl8.6
- tk
- tk-dev
@ -443,12 +445,12 @@
state: present
cache_valid_time: 3600
with_items:
- gcc-6-arm-linux-gnueabi
- gcc-6-mips-linux-gnu
- gcc-6-mipsel-linux-gnu
- gcc-6-powerpc-linux-gnu
- gcc-6-sparc64-linux-gnu
- gcc-6-s390x-linux-gnu
- gcc-8-arm-linux-gnueabi
- gcc-8-mips-linux-gnu
- gcc-8-mipsel-linux-gnu
- gcc-8-powerpc-linux-gnu
- gcc-8-sparc64-linux-gnu
- gcc-8-s390x-linux-gnu
when: ansible_distribution == 'Debian'
- name: Install misc. development tools

@ -44,8 +44,8 @@
- sshfs
- dosfstools
- davfs2
- cloop-utils
- ecryptfs-utils
# - cloop-utils
# - ecryptfs-utils
- smbclient
- name: Install database tools

Loading…
Cancel
Save